MongoDB\Driver\Exception\ConnectionException [ 15 ]: Server at coin-brothers-db:27017 reports wire version 0, but this version of libmongoc requires at least 3 (MongoDB 3.0)

/www/coin-brothers.com/vendor/mongodb/mongodb/src/Collection.php [ 269 ]

264     {
265         if ( ! isset($options['readPreference'])) {
266             $options['readPreference'] = $this->readPreference;
267         }
268 
269         $server = $this->manager->selectServer($options['readPreference']);
270 
271         if ( ! isset($options['readConcern']) && \MongoDB\server_supports_feature($server, self::$wireVersionForReadConcern)) {
272             $options['readConcern'] = $this->readConcern;
273         }
274 
  1. /www/coin-brothers.com/vendor/mongodb/mongodb/src/Collection.php [ 269 ] » MongoDB\Driver\Manager->selectServer(arguments)

  2. APPPATH/classes/Model/CMarketplace.php [ 431 ] » MongoDB\Collection->count(arguments)

  3. APPPATH/classes/Model/User.php [ 883 ] » Model_CMarketplace->get_market_count(arguments)

  4. APPPATH/views/nav.php [ 5 ] » Model_User->get_statistic()

  5. APPPATH/views/header.php [ 65 ] » require_once(arguments)

  6. SYSPATH/classes/Kohana/View.php [ 61 ] » include(arguments)

  7. SYSPATH/classes/Kohana/View.php [ 348 ] » Kohana_View::capture(arguments)

  8. SYSPATH/classes/Kohana/View.php [ 228 ] » Kohana_View->render()

  9. APPPATH/classes/Controller/Marketplace.php [ 123 ] » Kohana_View->__toString()

  10. SYSPATH/classes/Kohana/Controller.php [ 84 ] » Controller_Marketplace->action_market_search()

  11. {PHP internal call} » Kohana_Controller->execute()

  12. SYSPATH/classes/Kohana/Request/Client/Internal.php [ 97 ] » ReflectionMethod->invoke(arguments)

  13. SYSPATH/classes/Kohana/Request/Client.php [ 114 ] » Kohana_Request_Client_Internal->execute_request(arguments)

  14. SYSPATH/classes/Kohana/Request.php [ 986 ] » Kohana_Request_Client->execute(arguments)

  15. DOCROOT/index.php [ 117 ] » Kohana_Request->execute()

Environment